trinity-devel@lists.pearsoncomputing.net

Message: previous - next
Month: December 2012

Re: [trinity-devel] Build crash

From: Keith Daniels <keithwdaniels@...>
Date: Thu, 20 Dec 2012 11:20:53 -0500
Thanks Nik

I did try that command and I got the same dpkg-divert error.

Keith

On Thu, Dec 20, 2012 at 2:34 AM, Mag. Dr. Nikolaus Klepp
<office@...> wrote:
> you may try
>
> # apt-get install ksmserver-trinity
>
> Nik
>
> Am Donnerstag, 20. Dezember 2012 schrieb Keith Daniels:
>>  I have been trying to install R14 from the nightly builds on a Debian
>> Wheezy system that is completely up to date for the last couple of days.
>>
>>  Has anyone else tried an install from the nightly build link on Wheezy in
>> the last couple of days?
>>
>>  The error below makes no sense to me since I do not have plasma installed
>> nor any KDE4 packages and it is a new install.  I am "assuming" it is a
>> packaging error of some kind instead of a Trinity bug.
>>
>>  Does anyone have a clue as to what is going on or how to solve the
>> problem?
>>
>>  I get this error message:
>>
>>  (The important segment describing the error, is between the
>> "-----------------" bars:)
>>
>>
>>  ============================
>>
>>  Selecting previously unselected package tdebase-trinity.
>>  (Reading database ... 142161 files and directories currently installed.)
>>  Unpacking tdebase-trinity (from
>> .../tdebase-trinity_4%3a14.0.0-0debian12+r865+pr6~wheezy_all.deb) ...
>> Selecting previously unselected package
>> tdebase-runtime-data-common-trinity. Unpacking
>> tdebase-runtime-data-common-trinity (from
>> .../tdebase-runtime-data-common-trinity_4%3a14.0.0-0debian12+r865+pr6~wheez
>>y_all.deb) ...
>>
>>  -----------------
>>
>>  Unpacking ksmserver-trinity (from
>> .../ksmserver-trinity_4%3a14.0.0-0debian12+r865+pr6~wheezy_amd64.deb)...
>> dpkg-divert: error: `diversion of /usr/bin/plasma to /usr/bin/plasma.kde4
>> by ksmserver-trinity' clashes with `local diversion of /usr/bin/plasma to
>> /usr/bin/plasma.kde4' dpkg: error processing
>> /var/cache/apt/archives/ksmserver-trinity_4%3a14.0.0-0debian12+r865+pr6~whe
>>ezy_amd64.deb (--unpack): subprocess new pre-installation script returned
>> error exit status 2
>>
>>  -----------------
>>
>>  Errors were encountered while processing:
>>
>>  /var/cache/apt/archives/ksmserver-trinity_4%3a14.0.0-0debian12+r865+pr6~wh
>>eezy_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1)
>>  A package failed to install.  Trying to recover:
>>  dpkg: dependency problems prevent configuration of tdebase-trinity:
>>   tdebase-trinity depends on ksmserver-trinity (>=
>> 4:14.0.0-0debian12+r865+pr6~wheezy); however: Package ksmserver-trinity is
>> not installed.
>>
>>  dpkg: error processing tdebase-trinity (--configure):
>>   dependency problems - leaving unconfigured
>>  dpkg: dependency problems prevent configuration of
>> tdebase-runtime-data-common-trinity: tdebase-runtime-data-common-trinity
>> depends on tdebase-trinity; however: Package tdebase-trinity is not
>> configured yet.
>>
>>  dpkg: error processing tdebase-runtime-data-common-trinity (--configure):
>>   dependency problems - leaving unconfigured
>>  Errors were encountered while processing:
>>   tdebase-trinity
>>   tdebase-runtime-data-common-trinity
>>
>>  ============================
>>
>>  Keith
>
>
>
> --
>
> Mag. Dr. Nikolaus Klepp
> Einnehmerstra├če 14
> A-4810 Gmunden
> Tel.: +43 650 82 11 724
> email: office@...
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: trinity-devel-unsubscribe@...
> For additional commands, e-mail: trinity-devel-help@...
> Read list messages on the web archive: http://trinity-devel.pearsoncomputing.net/
> Please remember not to top-post: http://trinity.pearsoncomputing.net/mailing_lists/#top-posting
>