trinity-devel@lists.pearsoncomputing.net

Message: previous - next
Month: August 2013

Re: [trinity-devel] about pmount and R14 new backends

From: "E. Liddell" <ejlddll@...>
Date: Wed, 7 Aug 2013 21:42:44 -0400
On Wed, 07 Aug 2013 20:47:22 +0200
François Andriot <francois.andriot@...> wrote:

> Le 07/08/2013 20:35, Fat-Zer a écrit :

> > I can't say a lot about -DWITH_UPOWER, but if you switch it off you'll 
> > loose a suspend/hibernate functionality at least. Also will be 
> > affected the brightness and cpu governor control functionality.
> That's what I'm afraid of.
>  From what you know, can Upower be built on any (old) distribution, or 
> does it require recent kernel/libraries/etc .. ?

The significant runtime dependencies apper to be glib, dbus, polkit, udev, libusb, pm-utils.

The oldest upower I was able to find information for is 0.9.2, from April 2010.  It wants at least:
glib 2.21.5
dbus-glib 0.76
polkit 0.91
udev 151
pm-utils 1.3.0

The most recent I was able to find was 0.9.21, which wants:
glib 2.22
dbus-glib 0.100
polkit 0.110
udev 200
pm-utils 1.4.1 (or systemd 200)

I don't know what minimum version our hardware lib requires.