Message: previous - next
Month: August 2013

Re: [trinity-devel] ktorrent and avahi

From: "E. Liddell" <ejlddll@...>
Date: Tue, 13 Aug 2013 17:28:25 -0400
On Tue, 13 Aug 2013 11:46:42 -0500
"Darrell Anderson" <darrella@...> wrote:

> All,
> Does ktorrent depend upon avahi? I don't have avahi or avahi-tqt 
> installed. In the ktorrent build log I always see the following:
> checking for avahi-client >= 0.6.10... checking for avahi-tqt >= 
> 0.6.10... checking if apps should be compiled... yes
> ...
> KTorrent WARNING:
> Cannot find avahi-client with version 0.6.10 or later or
> cannot find avahi-tqt.
> The zeroconf plugin will not be installed because of this.
> Should there be a configuration option to explicitly exclude using 
> avahi?

ktorrent proper doesn't depend on avahi, but it has an optional
plugin that does, and by default the build system checks to see if
avahi is present.  There's an old Gentoo patch that I think is intended
to provide support for explicitly disabling avahi (thus killing the check 
and just not building the plugin) via a configuration option, but it 
obviously won't apply if ktorrent has been converted to CMake.

In other words, the warning is harmless if you're okay with autodetects,
but we may be able to fix it anyway.