Message: previous - next
Month: December 2013

Re: [trinity-devel] Minimum cmake version to compile Trinity

From: "Darrell Anderson" <darrella@...>
Date: Fri, 20 Dec 2013 18:28:31 -0600
>IMO it's a good idea to update at least to 2.6. Lower versions 
>definitely won't work...
>I'm not sure about 2.8. It may be only a �soft� limit. On the 
>other hand I
>don't suppose it will cause any problems... And nobody will test 
>compatibility with versions lower than 2.8... And nobody of users 
>would be
>able to because  tdelibs requres 2.8... so, go ahead =)
>NOTE: I'm just successfully built tdebase and tdelibs with cmake 
>versions 2.8.0 and 2.8.3.

The oldest release of Slackware that I can build Trinity is 13.1. 
In bug report 1741 I shared my attempts at building Trinity in 
Slackware 12.2 and 13.0. Ignoring cmake, newer versions of several 
upstream packages need to be backported to build Trinity in 
Slackware 12.2 or 13.0. Trinity builds in Slackware 13.1 just fine. 
Slackware 13.1 was released with cmake 2.8.1.

If we establish cmake 2.8 as a minimum requirement, we then --- 
indirectly --- include other problematic upstream packages against 
which Trinity would not build. That is, any distro that came with 
cmake 2.8 likely did not include the older upstream packages that 
would be problematic for building Trinity.