trinity-devel@lists.pearsoncomputing.net

Message: previous - next
Month: April 2014

Re: [trinity-devel] FTBFS: new "compton" does not build on older distro

From: "E. Liddell" <ejlddll@...>
Date: Tue, 1 Apr 2014 20:29:33 -0400
On Tue, 01 Apr 2014 20:00:01 +0200
Fran├žois Andriot <francois.andriot@...> wrote:

> Hello,
> I've noticed that the new "compton" stuff (from tdebase package) does 
> not build on RHEL6 :
[...]
> 
> The libconfig version is 1.3.2 .
> There is no "config_set_include_dir" anywhere in /usr/include/* .

It came in with libconfig 1.4, apparently, per
http://www.fvwmforums.org/phpBB3/viewtopic.php?f=37&t=2946

Try passing -DCONFIG_LIBCONFIG_LEGACY' , or equivalent?

E. Liddell