Message: previous - next
Month: September 2014

Re: [trinity-devel] R: [trinity-devel] New CMake warning CMP0026

From: Fat-Zer <fatzer2@...>
Date: Fri, 26 Sep 2014 10:49:01 +0400
2014-09-25 7:13 GMT+04:00 Michele Calgaro <michele.calgaro@...>:
> Hi Slavek,
> as a temporary solution, I would say let's set the use of OLD as you suggested and then file a bug report to adapt cmake scripts to the NEW way. This may require several changes (no idea how many or how few at the moment), so it would be better to leave it for after v14.0.0 is out.
> Nevertheless for the future we should do the switch from OLD to NEW, because it could be possible that sooner or later the OLD way would no longer be supported, no one knows.
> What do you think?
> Cheers
>   Michele
> PS: the next 3 or 4 days I won't be around at all.

There is no shame in keep using the OLD behavior... According to cmake
developer policy they will never drop support for old behaviors. On
the other hand if you adopt the new policy to be used in general you
drop support for the older cmake versions. But in this particular case
it seems that it may be possible to confirm the requires of new policy
without breaking the old stuff (may be not).