trinity-devel@lists.pearsoncomputing.net

Message: previous - next
Month: December 2015

Re: [trinity-devel] tdepim/kitchensync unmet dependencies + krb5.h on wheezy

From: Slávek Banko <slavek.banko@...>
Date: Sun, 20 Dec 2015 19:59:44 +0100
On Sunday 20 of December 2015 19:42:55 Michael Howard wrote:
> Apologies for following myself up but, having checked the 'Packages'
> file again, 'kitchensync-trinity' does indeed depend on 'libopensync0
> (>= 0.22)' which begs the question, how does one install 'tde-trinity'
> on a clean jessie (which I assume people have done?) when 'libopensync0'
> is not available in jessie? Without fiddling that is.
>
> Or, am I being a bit thick?

It is very easy - documentation for installation Trinity always says to use 
both the "main" repository, and "build-deps". So users do not have to deal 
with libraries that are not already included in the distribution, but are 
necessary for Trinity installation. See Trinity wiki:

https://wiki.trinitydesktop.org/DebianInstall

The problem therefore arises basically just for developers, because these 
packages are not managed in the GIT.

-- 
Slávek