trinity-devel@lists.pearsoncomputing.net

Message: previous - next
Month: January 2017

building for Stretch

From: deloptes <deloptes@...>
Date: Wed, 25 Jan 2017 19:36:34 +0100
Hi,

I'm trying to finish the syncevolution story and I wanted to test building
on a clean stretch system. For this I tried to build tde deb packages from
scratch. I am wondering if you have targeted stretch already, because I had
multiple issues. I have seen that Slavek is already doing some changes.
Here is the summary of all.

The biggest problem I face is tdelibs depending on libpkcs11-helper1-dev
depending on libssl1.0-dev, but other packages still depend on libssl-dev.
Is it what Michele meant that needs to be solved?

===================

tqca-tls:
         depends on libssl-dev should be either libssl-dev or 
libssl1.0-dev

tdelibs/tdepim:
         has dependency on libacl1-dev since trashbin props are 
extended -> add to dependency list
         has dependency on hspell - why?
         depends on libssl-dev -> should be either libssl-dev or 
libssl1.0-dev


dpkg-gencontrol: error: Depends field of package tdelibs-trinity: 
obsolete substitution variable ${Source-Version}
     /usr/share/cdbs/1/rules/debhelper.mk:346: recipe for target 
'binary-makedeb-IMPL/tdelibs-trinity' failed
     make: *** [binary-makedeb-IMPL/tdelibs-trinity] Error 2

     resolved - change in debian/control -> Source-Version => source:Version

tdelibs: this is just a warning - why is it kubuntu, when I am on debian?
     utf8 "\xEA" does not map to Unicode at 
debian/kubuntu-desktop-i18n/createdesktop.pl line 60, <FH> line 1235.


tdeldap: This is annoying -> could be done automatically?
        make -f admin/Makefile.common followed by libtoolize

tdeutils: libsnmpkit-dev instead of libsnmp-dev
        resolved - change in debian/control -> Source-Version => source:Version

tdenetwork: 
        fails on libslp1 missing. libslp1 is missing in stretch
        ported from jessie
     
http://linux.debian.bugs.rc.narkive.com/dCWqJMGf/processed-re-bug-795428-openslp-1-2-should-not-be-part-of-stretch
     http://git.net/ml/debian-qt-kde/2016-02/msg00645.html
        resolved - change in debian/control -> Source-Version => source:Version

tdepim: depends on libssl-dev, conflicts with libpkcs11-helper1-dev 
libssl1.0-dev
        Unable to locate package liblockdev1-dev - backported from jessie
        resolved - change in debian/control -> Source-Version => source:Version
        dh_installdeb: Compatibility levels before 9 are deprecated (level 5 
in use)


tdeaddons:
        resolved - change in debian/control -> Source-Version => source:Version

===================
In each package I have in the beginning and end a kind of macro saying
     Scanning upstream source for new/changed copyright notices...

     set -e; LC_ALL=C.UTF-8 /usr/bin/licensecheck --check '.*' 
--recursive --copyright --deb-fmt --ignore 
'^(debian/(changelog|copyright(|_hints|_newhints)))$' --lines 0 * | 
/usr/lib/cdbs/licensecheck2dep5 > debian/copyright_newhints

This takes too long and is annoying

===================
While trying to clean up already installed packages it looks like in stretch
update-alternatives is not in /usr/sbin but in /usr/bin

I solved it for now by
ln -s /usr/bin/update-alternatives /usr/sbin/update-alternatives

but I guess it needs to be updated all around packages


Thanks