trinity-devel@lists.pearsoncomputing.net

Message: previous - next
Month: March 2017

Re: [trinity-devel] Missing dependencies installing trinity-desktop on Suse Leap 42.x

From: Felix Miata <mrmazda@...>
Date: Tue, 28 Mar 2017 02:26:33 -0400
Fran├žois Andriot composed on 2016-05-14 05:42 (UTC-0400)
...
 > Hello, the 'libaudio.so.2' files comes in the 'libaudio2' package, which
 > should be available on Packman.
 > 'libIlmImf-2_2.so.22' is available in package 'libIlmImf-2_2-22' from
 > Packman too.

 > I'm not sure why it's not in the repository right now, maybe it's
 > currently updating ...

Packman is nearly always updating. :-( There ought to be a way to get TDE to 
install without hard depends on Packman, having to choose between breaking newly 
installed packages, or not installing at all until some other random day. Can't 
install in 42.1 either:

# grep RETT /etc/*lease
/etc/os-release:PRETTY_NAME="openSUSE Leap 42.1 (x86_64)"

# zypper lr
#  | Alias          | Name           | Enabled | GPG Check | Refresh
---+----------------+----------------+---------+-----------+--------
...
  8 | Packman        | Packman        | Yes     | (r ) Yes  | No
  9 | TDE            | TDE            | Yes     | (  ) No   | No
10 | TDEnoarch      | TDEnoarch      | Yes     | (  ) No   | No
...

# zypper -v in trinity-arts trinity-gtk-qt-engine
Verbosity: 1
Non-option program arguments: 'trinity-arts' 'trinity-gtk-qt-engine'
Initializing Target
...
Loading repository data...
Reading installed packages...
Force resolution: No
Selecting 'trinity-arts-2:1.5.10-14.0.4_1.oss421.x86_64' from repository 'TDE' 
for installation.
Selecting 'trinity-gtk-qt-engine-2:0.8-14.0.4_1.oss421.x86_64' from repository 
'TDE' for installation.
Resolving package dependencies...
Force resolution: No
2 Problems:
Problem: nothing provides libIlmImf-2_2.so.22()(64bit) needed by 
trinity-tdelibs-14.0.4-1.oss421.x86_64
Problem: nothing provides libaudio.so.2()(64bit) needed by 
libtqt3-mt-3.5.0-14.0.4_1.oss421.x86_64

Problem: nothing provides libIlmImf-2_2.so.22()(64bit) needed by 
trinity-tdelibs-14.0.4-1.oss421.x86_64
  Solution 1: do not install trinity-gtk-qt-engine-2:0.8-14.0.4_1.oss421.x86_64
  Solution 2: break trinity-tdelibs-14.0.4-1.oss421.x86_64 by ignoring some of 
its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c): 1
Applying solution 1

Problem: nothing provides libaudio.so.2()(64bit) needed by 
libtqt3-mt-3.5.0-14.0.4_1.oss421.x86_64
  Solution 1: do not install trinity-arts-2:1.5.10-14.0.4_1.oss421.x86_64
  Solution 2: break libtqt3-mt-3.5.0-14.0.4_1.oss421.x86_64 by ignoring some of 
its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c): 1
Applying solution 1
Resolving dependencies...
Resolving package dependencies...
Force resolution: No
-- 
"The wise are known for their understanding, and pleasant
words are persuasive." Proverbs 16:21 (New Living Translation)

  Team OS/2 ** Reg. Linux User #211409 ** a11y rocks!

Felix Miata  ***  http://fm.no-ip.com/