Message: previous - next
Month: August 2011

Re: [trinity-devel] LibreOffice 3.4.2

From: Ilya Chernykh <anixxsus@...>
Date: Wed, 17 Aug 2011 07:52:37 +0400
On Wednesday 17 August 2011 07:46:40 Robert Xu wrote:

> >> TQt intergration.
> >
> >> Not with Trinity. See above.
> >
> > I think the reason why it does not work in Ubuntu is different.
> What do you mean?! it works in Ubuntu.

I meant KDE3 integration.

> > On the other hand if the problem is actually in that it is not conpatible with tqtintegface,
> > and requires rewrite, this shows that you people went too far in breaking compatibility with
> > existing KDE3 software.
> >
> I am so confused now. What are you getting at?
> What doesn't make sense?
> It's easy to be compatible with TQt - it doesn't need a complete rewrite.
> It's not so hard to put a T in front of every Qt call.

And why to do this if anyone just can call plain Qt3? Why do you need libreoffice
to call tqtinterface rather than just Qt?

> We didn't break compat with existing KDE3 at all. We're just making it
> easier to port to Qt4 when the time comes.

Libreoffice has its own front-end for Qt4. Just use this front-end when your
system is built against Qt4.