Message: previous - next
Month: November 2011

Re: [trinity-devel] configure: error: Qt (>= Qt 4.3 and < 5.0)...

From: Darrell Anderson <humanreadable@...>
Date: Wed, 9 Nov 2011 17:29:36 -0800 (PST)
> No, I tried on a 32-bit Slackware 13.1 with the 64-bit
> kernel
> from Slackware64 13.1. But I didn't remove any L-series
> package other
> than Qt4, it must explain the differences between our
> results :)
> I currently dual-boot Slackware 13.1 (with Trinity as main
> desktop)
> and Slackware64 13.37 (with KDE4 as main desktop), but with
> only
> 64-bit kernels.
> I did partial builds of Trinity on both systems, and except
> for the
> broken 13.37 libical, I didn't see actual differences
> between 13.1 and
> 13.37 in terms of building the dependencies, kdebase,
> kdelibs and
> kdepim (which are the only packages I built on 13.37); but
> I won't be
> able to build full Trinity in 13.37 because it is my KDE4
> system, from
> which I won't remove KDE4 packages.
> > 
> > I hope to try building in a 13.37 virtual machine.

Okay. I'll check which packages in my build environment I removed from the stock 13.1 system.

I am not running 64-bit. Likewise with my 13.37 virtual machine. :(

Several days ago I filed a bug report (582) that I could not build Trinity without removing qt4. As my 13.1 build environment does not include a bunch of KDE4 packages, I still have to test using Trinity in a 13.1 stock system to see whether any obvious QT4/KDE4 conflicts exist. I have yet to test Trinity 3.5.13 at all. :) I'm running another complete build pass right now to ensure that part is okay.