trinity-devel@lists.pearsoncomputing.net

Message: previous - next
Month: February 2012

Re: [trinity-devel] Building Trinity with older distros

From: Darrell Anderson <humanreadable@...>
Date: Fri, 10 Feb 2012 18:38:25 -0800 (PST)
> > Is this possible?
> > 
> > I'm not asking for support. I only want to know whether
> Trinity will
> > build on older distros. Has anything been done to
> Trinity that
> > prevents building on older distros? That is, KDE 3.5.10
> goes quite a
> > few years back and could still be built today with
> older distros, but
> > will Trinity build?
> Fran├žois Andriot has already built Trinity 3.5.13 on RHEL5,
> which age is
> approximately the same as Slackware 11.0. The KDE e.V.
> publishes a list
> of requirements of KDE 3.5 here:
> http://www.kde.org/info/requirements/3.5.php
> so it may actually build, with some features disabled, with
> much older
> Slackware versions (Slackware 8.1 is the first one to
> provide
> simultaneously GCC 2.95, zlib 1.1 and libpng 1.2 by
> default).
> Obviously some new packages will be needed (at least CMake
> 2.8).

Okay, thanks everybody. Contemplating a rainy day project. :)

Darrell