Also, the version of crystal in the tde git tree is 1.0.5 according to the
documentation with it. We should build with 1.0.7.

Yes, you are right.
Today i replaced the configure file in current git, with the configure file from 1.0.7 source. It configures OK but the build fails at the library. Am looking through it now.

Jay

On Sat, Feb 25, 2012 at 2:48 AM, David C. Rankin <drankinatty@...> wrote:
On 02/24/2012 08:46 PM, E. Liddell wrote:
> export kde_widgetdir="$KDEDIR/$(get_libdir)/kde3/plugins/designer"
>
> I wasn't able to find mention of it anywhere else, so it's possible this
> was a general KDE3 configuration variable intended to point to the
> designer plugins, and that exporting it (or "tde_widgetdir") with the
> correct value might help.
>
> It's also possible that this information is distro-specific or otherwise
> useless, but I thought I would toss it in.

No,

 There is actually a

/opt/trinity/lib/trinity/plugins directory that holds the libraries that are
being looked for. The problem is the source code wants to find the libraries in

/opt/trinity/lib/kde3/plugins

So since there was a rename from ${TDEDIR}/lib/kde3 to ${TDEDIR}/lib/trinity
there is no real easy quick-fix in the crystal source to handle this. I know it
is fairly easy to solve, it just takes time to hunt and peck through the
configure files and the aclocal/libtool stuff that I know "squat" about, but I'm
learning.

Also, the version of crystal in the tde git tree is 1.0.5 according to the
documentation with it. We should build with 1.0.7.

--
David C. Rankin, J.D.,P.E.

---------------------------------------------------------------------
To unsubscribe, e-mail: trinity-devel-unsubscribe@...
For additional commands, e-mail: trinity-devel-help@...
Read list messages on the web archive: http://trinity-devel.pearsoncomputing.net/
Please remember not to top-post: http://trinity.pearsoncomputing.net/mailing_lists/#top-posting