trinity-devel@lists.pearsoncomputing.net

Message: previous - next
Month: April 2012

Re: [trinity-devel] Re: Resolving the TWin/KWin Fork Issue

From: Francois Andriot <francois.andriot@...>
Date: Sat, 21 Apr 2012 11:49:44 +0200
Le 21/04/2012 11:17, Martin Gräßlin a écrit :
> On Saturday 21 April 2012 09:57:36 François ANDRIOT wrote:
>> All distro do not have the bleeding edge QT4 or KDE4 version. For
>> example, RHEL use QT 4.6 and KDE 4.3 .
>> In that case, is TDE supposed to provide QT 4.7 (or newer) and the
>> latest kdelibs just to provide the latest kwin ? I don't think so.
> I highly recommend to not use KWin 4.3 anymore. And RHEL or SLES are very bad
> examples. Users of those want the old versions and do neither want to install
> a recent version of KDE software nor of TDE software. They use the old system
> because of the provided security by RedHat or SUSE. Installing anything third
> party invalidates the reason to use RHEL/SLES in the first place.

Well, in fact, I'm using RHEL at work (I've not chosen to, It was 
already there).
Some day I opened a support case to indicate that the KDE4 they provided 
did not work as expected, whereas KDE3 had no problem in previous RHEL 
releases.
The only answer I got from RH was "would you mind switching to gnome ?".

The funny thing is that, if they had solved my KDE4 problem, I would 
never have built TDE for RHEL :-)
The TDE community can thank the RHEL tech support.

> kwin 4.3 does not use anything of Nepomuk. That indirect and optional 
> runtime (!) dependency got added around 4.7. Cheers Martin 
Okay, nepomuk was just an example, I do not know what Kwin 4.3 requires 
exactly to run.
My wish is that we could install a kwin4 version on every distro, that 
would NOT require a QT4 upgrade and/or lots of unwanted KDE4 stuff .

My guess is that kwin 4.9 will not build against older qt4/kde4.
That's why I suggested to stick with the distribution-provided Kwin 
version, modifying just the small parts that we want.

If I'm wrong and that there is a way to build Kwin 4.9 on older 
QT4/KDE4, I would of course prefer using Kwin 4.9 .

Francois