Message: previous - next
Month: August 2010

Re: [trinity-devel] Building From SVN

From: Darrell Anderson <humanreadable@...>
Date: Wed, 25 Aug 2010 23:35:04 -0700 (PDT)
> <snip>
> > but krb5 is not a requirement in Slackware.
> >
> > Let me know what you need.
> >
> </snip>
> That was part of it! ;-)
> Is the previously mentioned error still occurring in the
> virtual machine
> build?  It may have originally arisen due to the old
> KDE3.5.10 header
> files, and krb5 may be a red herring.  I will wait for
> the build log from
> the virtual machine before passing judgment.

I sent the build log in a previous message.

As a comparison test, I built the kdelibs package with the stock 3.5.10 and there were no messages about -lgssapi_krb5. Thus something has changed since then. :)

I searched the kdelibs sources and found only two files using the lgssapi_krb5 term:

kdelibs/kioslave/http/      GSSAPI_LIBS="${GSSAPI_LIBS}-lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err ${LIBRESOLV}"

kdelibs/kioslave/http/ = $(all_libraries) $(GSSAPI_RPATH) -module $(KDE_PLUGIN) -lgssapi_krb5

The kdelibs/kioslave/http/ files in svn and 3.5.10 are identical.

I looked at the two configure files but found nothing obvious why the svn version requires krb5.

The configure --help output mentions a --with-gssapi= option, but I found no clue as to which option to pass to disable that support. I tried NOTFOUND but that did not work.

Hopefully this information helps you!