Message: previous - next
Month: April 2012

Re: [trinity-devel] kcmshell keys

From: "E. Liddell" <ejlddll@...>
Date: Sun, 29 Apr 2012 18:59:41 -0400
On Sun, 29 Apr 2012 13:58:26 -0700 (PDT)
Darrell Anderson <humanreadable@...> wrote:

> > While i havn't yet built Virtualbox under tqt3 i have had no trouble running Virtualbox in any
> > previous release using qt3. Virtualbox is released alongside our official release (Porteus).
> Are you saying that more recent versions of VirtualBox can be built against Qt3? I was under 
>the impression that after version 2.2.4 or thereabouts only Qt4 could be used.

Fishing through the ebuild shows that QT4 is definitely optional (switch --disable-qt4).
However, I'm not sure what kind of GUI, if any, you'd get without it—the other deps 
specified for a non-QT4, non-headless build don't include a widget set, just SDL, 
OpenGL, and some X libs.  An SDL-based GUI is possible, I suppose, but it's a bit