Message: previous - next
Month: May 2012

kipi-plugins patch (gcc 4.7 + libpng 1.5) [was Re: [trinity-devel] kipi-plugins FTBFS libpng 1.5 - fixed?]

From: "David C. Rankin" <drankinatty@...>
Date: Fri, 04 May 2012 14:00:39 -0500
On 05/04/2012 01:04 PM, David C. Rankin wrote:
> On 05/04/2012 12:52 PM, Darrell Anderson wrote:
>>>   I was thinking Darrell already had a patch for this
>>> that allowed it to build w/o -fpermissive. This might just
>>> be one of the -fpermissive issues that needs fixing. Anybody
>>> know if a patch exists for this on gcc 4.7?
>> There was no libpng patch for kipi-plugins. I'm curious why I never saw the same build failure. My log shows the warnings but not the failure.
>> If a patch is needed, look at what we did for digikam:
>> Darrell
> OK,
>   This is one that does build with -fpermissive, but I was eliminating those
> from the initial gcc47 build scripts. I'll have a look. I'm certain it will be a
> simple fix -- the only question will be -- how long it takes me to see it :)

Holy crap! It worked!

  Somebody who knows what they are doing, please sign off on this patch. If OK,
then Darrell can go ahead and push. It builds fine with gcc 4.7 and libpng 1.5
-- and -- eliminates the '-fpermissive' build flag.

David C. Rankin, J.D.,P.E.