Message: previous - next
Month: May 2012

Re: [trinity-devel] kipi-plugins patch (gcc 4.7 + libpng 1.5) [was Re: [trinity-devel] kipi-plugins FTBFS libpng 1.5 - fixed?]

From: "David C. Rankin" <drankinatty@...>
Date: Fri, 04 May 2012 22:49:46 -0500
On 05/04/2012 08:44 PM, Mike Bird wrote:
> Because the compiler can warn you if somebody changes a
> declaration and the cast turns into something other than
> a static cast.
> It's better to use a static_cast, dynamic_cast, const_cast
> or reinterpret_cast than the old-fashioned cast which can
> try too hard when you'd rather have a warning.

Right now, the compiler will not accept it though. You get a FTBFS with the 2nd
patch, the first patch builds fine. How do we fix the 2nd patch?

David C. Rankin, J.D.,P.E.