trinity-devel@lists.pearsoncomputing.net

Message: previous - next
Month: September 2012

Re: [trinity-devel] 3.5.13-sru Test [print] -> ksnapshot gesture (didn't work on last build)

From: Slávek Banko <slavek.banko@...>
Date: Wed, 5 Sep 2012 03:18:13 +0200
On Tuesday 04 of September 2012 21:44:09 David C. Rankin wrote:
> On 09/03/2012 10:25 AM, Slávek Banko wrote:
> > Dne čt 30. srpna 2012 Slávek Banko napsal(a):
> >> On Wednesday 29 of August 2012 19:10:16 Slávek Banko wrote:
> >> I have a track to problem, which leads to not functional PrintScreen! I
> >> was looking for, where is ensured functionality of PrintScreen and I
> >> found that in KHotKeys. Then I found out they do not work any more
> >> keyboard shortcuts that I have in KHotKeys. When I tried to manually
> >> start KHotKeys, keyboard shortcuts, including Printscreen started to
> >> work.
> >>
> >> I was looking for that KHotKeys are run as a service - using kded. But
> >> for some reason, probably will not start. I checked that all three
> >> khotkeys.desktop are essentially identical with those in 3.5.12. The
> >> difference can be seen in the *khotkeys*.la - dependency_libs is now
> >> empty. It might be important?
> >>
> >> Slavek
> >
> > I have one interesting observation: When I'm on my machine manually once
> > started KHotKeys (then I killed him again), since then everything works
> > fine.
> >
> > On the test machine, then I see another problem - KHotKeys not load
> > default actions - so even PrintScreen.
> >
> > Slavek
>
> This is great work! Something is killing it gestures. I can't explain why
> it appears to start sometimes and not others. One observation I have is
> that if it 'works' in a build, it will 'always work', but for some reason
> if it does not work after a build, then is seems to always 'not' work.
> Tracking it down to KHotKeys may help the issue with kded and why it starts
> sometimes and not other times (that may be the 'k' -> 't' issue I am seeing
> in my last 3.5.13-sru build. My experience has been:
>
> 3.5.12     -> Always Worked
> 3.5.13-sru -> Always worked up to 8/14 build then stopped
> 14.0.0     -> Worked until 4/18 build, fixed, 7/17 broke again
>
> I'm glad you can at least track it to KHotKeys and get it working by
> manually starting KHotKeys. That helps.
>
> I'm still swamped at work. Hopefully, next week or it will ease up.

If I remember correctly, I tried it in the original 3.5.13 and even there 
PrintScreen not work. As the beginning of the problem I see that 
khotkeys-update does not import the default keyboard shortcuts.

Slavek
--