cd /build/src/BUILD/kbabel/common/libgettext && /usr/bin/lex -+ -opofiles.cpp /trinity.source/kdesdk/kbabel/common/libgettext/pofiles.ll

this line and the "ll" ? let me search some?

On Tue, May 3, 2011 at 5:46 PM, Baho Utot <baho-utot@...> wrote:
On 05/03/2011 05:18 PM, Serghei Amelian wrote:
On Wednesday 04 May 2011 00:08:51 Baho Utot wrote:
On 05/03/2011 04:44 PM, Serghei Amelian wrote:
On Tuesday 03 May 2011 23:41:29 PICCORO McKAY Lenz wrote:
umm please send more info.. version of flex ( 2.5.4 series or 2.5.3X
series, try lower version for confirm.. ) and even u said its not script
, but please, re-check..

the line "

flex: Can't use -+ with -l option

said that theres a "-+" wrong option parsing here on way!

On Tue, May 3, 2011 at 4:08 PM, Baho Utot<baho-utot@...>  
wrote:
  On 05/03/2011 10:10 AM, PICCORO McKAY Lenz wrote:

what version on flex?

u r' using flex minor than 2.5.4 series or 2.5.3X series

seeems that u parse a wrong option "-+" please check u script or send
more info,
Actually is not wrong option, but seems that Baho's flex won't use it
together with -l. Baho, try to remove "-l" flag and tell me if working.
I don't know what file that I need to change as I don't know anything
about flex.

I have looked at the files in
trinity.source/kdesdk/kbabel/common/libgettext
common/libgettext/CMakeLists.txt

But there is not used -l flag, I don't know why you receive this error.

I have no clue

I am using flex 2.5.35
My flex is 2.5.35 either and seems ok.


Here is the error with verbose turned on and without -j8


/usr/bin/cmake -E cmake_progress_report /build/src/BUILD/CMakeFiles  100
[ 39%] Built target umbrello-en-handbook
make -f kbabel/common/libgettext/CMakeFiles/gettext-static.dir/build.make kbabel/common/libgettext/CMakeFiles/gettext-static.dir/depend
make[2]: Entering directory `/build/src/BUILD'
/usr/bin/cmake -E cmake_progress_report /build/src/BUILD/CMakeFiles
[ 39%] Generating pofiles.cpp
cd /build/src/BUILD/kbabel/common/libgettext && /usr/bin/lex -+ -opofiles.cpp /trinity.source/kdesdk/kbabel/common/libgettext/pofiles.ll
flex: Can't use -+ with -l option
make[2]: *** [kbabel/common/libgettext/pofiles.cpp] Error 1
make[2]: Leaving directory `/build/src/BUILD'
make[1]: *** [kbabel/common/libgettext/CMakeFiles/gettext-static.dir/all] Error 2
make[1]: Leaving directory `/build/src/BUILD'
make: *** [all] Error 2
==> ERROR: A failure occurred in build().


copying the subdirectory contents to tmp (mkdir /tmp/test && cp -va /trinity.source/kdesdk/kbabel/common/libgettext/* /tmp/test)
and running flex --verbose results in

 /usr/bin/lex --verbose -+ -opofiles.cpp pofiles.ll
flex: Can't use -+ with -l option
flex version 2.5.35 usage statistics:
  scanner options: -+lv8 -Cem -opofiles.cpp -PGettextBase
  2/2000 NFA states
  0/1000 DFA states (0 words)
  -1 rules
  No backing up
  1/40 start conditions
  2 epsilon states, 0 double epsilon states
  no character classes
  0 state/nextstate pairs created
  0/0 unique/duplicate transitions
  0/1000 base-def entries created
  0/2000 (peak 0) nxt-chk entries created
  0/2500 (peak 0) template nxt-chk entries created
  0 empty table entries
  0 protos created
  0 templates created, 0 uses
  0/256 equivalence classes created
  0/256 meta-equivalence classes created
  0 (0 saved) hash collisions, 0 DFAs equal
  0 sets of reallocations needed
  256 total table entries needed

Can you see any problems?






--
Lenz McKAY Gerardo (PICCORO)
http://qgqlochekone.blogspot.com
Cofundador de Venenux;  debian based multimedia alike free only zealots users (oh well, i try but..too many free guidelines buahhh)
http://shutendouji.net
creador de massenkoh linux; debian enhanchements for better up to date support on stable brand, including non-free soft.