Message: previous - next
Month: February 2011

Re: [trinity-devel] Trinity on Arch - Intel Atom (new thread)

From: "David C. Rankin" <drankinatty@...>
Date: Tue, 22 Feb 2011 21:39:34 -0600
On 02/22/2011 07:02 PM, calvin morrison wrote:
> It seems this is a case where we would need a make-conflict. but that
> doesn't exist in PKGBUILDs arrays. Fogobogo suggest that we add it to
> our make depends and require that (qt < 4).
> Can we resolve this issue another way?
> Calvin

I think all of this can be handled in the CMake files, but it will take detailed
effort from somebody way smarter than I am to insure the CMake build process
only uses the proper Qt version and proper libraries associated with the
DCMAKE_INSTALL_PREFIX=${trinity_prefix}, -DWITH_QT3=ON, -DQTDIR=/opt/qt or
similar options.

I know cmake can do it, I just don't know how or where to tell it to do it :(
That's why after fighting the weird build errors and trying to prevent the build
from looking in /usr for includes and Qt libraries, I just threw in the towel
and set up a clean build environment. (it also let me catch all needed
dependencies and specify them in the PKGBUILDs)

David C. Rankin, J.D.,P.E.